View Single Post
Old 04-19-2009, 09:44 AM  
Junior Member
Join Date: Apr 2009
Posts: 3
Exclamation Please help ! Please help ! Please help ! Please help !

Originally Posted by Yil View Post
The FTP reports all timestamps in GMT/UTC so I'm guessing you're 2 hours off GMT. The REAL question is whether or not the directory timestamp is being updated when the contents of the directory are being changed. The system should update it when a file is created/removed, but will not do so if an existing file is modified... Assuming this happens when the the file is removed I don't see why the server won't go to disk because it invalidates the cache if the timestamp differs. Resolution on NTFS is 100ns which is fast enough that shouldn't be an issue but FAT is 2 seconds which could be the problem.

There are ways to make ioFTPD invalidate cached dirs which is what a script would normally do.

Easiest solution might just be to make your script wait 5 seconds after it sees a file appear assuming you are using FAT and the possible 2 second resolution is the issue... Or have the script update the timestamp on the dir after 5 seconds goes by or something...

Correct, I am using FAT32. What you wrote would make sense with deleted file. BUT it doesn't make sense with data that are being downloaded - file is modified, but it still have to be visible! I don't think directory timestamp is updated as I checked "Pre-allocate all files" option:

However, If I disable this option, I have the same result.

Do you think option "Move completed downloads to" would help?

Please note that it's not a script that is doing it, but "Automatically load .torrents from / Delete loaded .torrents" options. I cannot use your solution. What is the other options to make ioFTPD invalidate cached dirs?

This is critical bug as files on the disk are different from files visible via FTP!
ioftpd1981 is offline   Reply With Quote